Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 31, 2025 - 23:45 UTC
Scheduled
Dear Customer, from April 1st this status page will stop receiving updates and later on will be decommissioned as part of the migration to new status pages project. All information on accessing your new status page is shared with you via Salesforce case 00236756.
Posted Mar 28, 2025 - 13:59 UTC
This scheduled maintenance affected: Acesso Mambu Production.